[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help with fonts (Was: Non-latin scripts howto?)

From: Gilles
Subject: Re: Help with fonts (Was: Non-latin scripts howto?)
Date: Tue, 22 Nov 2005 18:21:07 +0100
User-agent: Mutt/1.5.11


> How can I investigate further what's wrong on my system?
> Here attached:
> - a LilyPond file edited with gedit (to insert Hebrew)
> - a pdf output of that text file, showing that a Hebrew font is accessible
>   since it shows up here
> - the pdf output of lilypond, with no Hebrew characters :-{
> Results of compiling this file on another Debian system would help...

Hmm, no replies: I'm a bit disappointed; doesn't anybody experience this

Here is further information.
I ran

$ lilypond -b svg

where "" is a utf8 encoded file (here attached again) containing
Hebrew characters.
I then opened it with "gimp" and saved it as "png" [1].  The resulting
image is also attached [2].
As you can see, the Hebrew characters are there.
So, what's the problem that would cause the default backend not to produce
these characters?
Or is the problem further down (ghostscript et al.)  [If that's the case,
I'll report the bug against the "gs-gpl" Debian package.]

Best regards,

[1] I tried first the "png" backend, but it failed with:

/usr/share/lilypond/2.6.3/ly/ error: GUILE signaled an error for 
the expression beginning here
 (if (pair? toplevel-scores)unbound variable: output-framework

/usr/share/lilypond/2.6.3/ly/ error: syntax error, unexpected '(', 
expecting '='
     (pair? toplevel-scores)
error: failed files: ""

[2] The svg output of music is seriously messed up.  A known bug?
    But this is for another thread...

Description: Text document

Description: Zip archive

reply via email to

[Prev in Thread] Current Thread [Next in Thread]