[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LilyPond hangs at "parsing"

From: Mats Bengtsson
Subject: Re: LilyPond hangs at "parsing"
Date: Fri, 28 Jul 2006 21:32:51 +0200
User-agent: Internet Messaging Program (IMP) H3 (4.0.4)

Make sure that "Unicode" means UTF-8 and nothing else.


Quoting "Palmer, Ralph" <address@hidden>:

Hi -

I'm running LilyPond under Window XP SP2.

I recently switched from jEdit to ConTEXT (with the new LilyPond
highlighter). I had no problem for a few days; then suddenly yesterday
LilyPond started to hang. I can't get my files to complete. The only
global change I can remember making yesterday was to convert text from
DOS to Unicode. In order to find the source of the problem, I started
commenting out my music. I got all the way back to the first measure,
with no success. So, I tried a new file:


\version ""
Music = {
     \clef treble
     \key c \major
     \time 4/4
     \tempo 4=112

        a'4 b'4 c'4 d'4


\score {

End Snippet

I typed all of it fresh - no copy and paste. When I run it, I get the
same message in the log, with no .ps or .pdf produced. Here's the log:

# -*-compilation-*-
Changing working directory to `C:/Documents and Settings/rpalmer/My
Documents/Ralph/Sheet Music/LilyPond/Classical/Deak/Lad a dog'
Processing `C:/Documents and Settings/rpalmer/My Documents/Ralph/Sheet
Music/LilyPond/Classical/Deak/Lad a dog/section'

I had an old file that was not converted to Unicode, and it compiled
correctly. Does this look familiar to anyone? I hope it doesn't mean I
have to retype all my music.

Thanks for your help,

Ralph Palmer
Energy/Administrative Coordinator
Keene State College
Keene, NH 03435-2502
Phone: 603-358-2230
Cell: 603-209-2903
Fax: 603-358-2456

lilypond-user mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]