[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

OOoLilyPond macro installation and use

From: Gordon Gilbert
Subject: OOoLilyPond macro installation and use
Date: Mon, 16 Oct 2006 18:50:53 -0400 (EDT)

Hi folks!

I looked at this idea of OOoLilypond, and thought -- what a fabulous idea for how I use Lilypond! So I installed the latest Lily (2.9.23), and installed and followed slavishly the instructions to download and install the macro.

But it won't work! It seemed to install just fine, although when I went to bind the macro, I had trouble following the instructions. The biggest thing in that was that you used the word "Append" as part of the menu instructions. After some cogitation, I figured out that the menu button I should try is "Import".

So now I had the macro installed, and I opened it, and inserted the lily code. When I clicked Lilypond, it crashed OpenOffice. OOo was kind enough to "recover" my document upon reopening, but now, when I type <Ctrl>-M, I get a dialog with the following cryptic text in it:

A Scripting Framework error occurred while running the Basic script

Message:  BasicProviderimpl::getScript: no script!

Can anybody help me here? I should say that I did this on my FreeBSD machine just now as I was composing the email. but I installed the macro on my Windoze machine as well, but it simply wouldn't work on that. Maybe somebody could help there too. (Windows XP Pro, Lilypond 2.9.23-1)


Fr. Gordon Gilbert

        |                 Angels' Roost Farm                  |
        |       Rev. Fr. Gordon Gilbert & Susan Gilbert       |
        |                   705-549-5056                      |
        |                address@hidden                  |
        |                address@hidden                 |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]