[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: OOoLilyPond macro installation and use

From: Daniel Tonda Castillo
Subject: Re: OOoLilyPond macro installation and use
Date: Thu, 19 Oct 2006 21:57:25 -0500
User-agent: Thunderbird 3.0a1 (X11/20060816)

I've tried the OOoLilypond and after a change in openoffice version or a change in lilypond it somehow puts the version of the lilypond back to 2.6.

I changed it back, and checked the path for the macro and it worked.

Daniel T.

Gordon Gilbert wrote:
Samuel Hartmann wrote:
Hi Gordon,

Gordon Gilbert wrote:
Hi folks!

I looked at this idea of OOoLilypond, and thought -- what a fabulous idea for how I use Lilypond! So I installed the latest Lily (2.9.23), and installed and followed slavishly the instructions to download and install the macro.

I don't expect OOoLilyPond to work with LilyPond 2.9.23. Use a stable version of LilyPond for which the corresponding templates are available (I recommend the version 2.6 for use with OOoLilyPond) .

But it won't work! It seemed to install just fine, although when I went to bind the macro, I had trouble following the instructions. The biggest thing in that was that you used the word "Append" as part of the menu instructions. After some cogitation, I figured out that the menu button I should try is "Import".
Maybe the the button is called differently in different versions of I'm using 2.0.2 that comes with Ubuntu Dapper.

But anyhow. The installation procedure is too complex. The next development step of OOoLilyPond will be to simplify the installation.

So now I had the macro installed, and I opened it, and inserted the lily code. When I clicked Lilypond, it crashed OpenOffice. OOo was kind enough to "recover" my document upon reopening, but now, when I type <Ctrl>-M, I get a dialog with the following cryptic text in it:

A Scripting Framework error occurred while running the Basic script

This error appears when does not find the macro anymore. Usually it helps to once again assign Ctrl-M to tha macro. It may also be that you have to repeat the complete Installation procedure.



Hi again,

I tried going with 2.8.7, and installed the macro just as instructed, and it still crashed OO. Any ideas?

Attachment: daniel.tonda.vcf
Description: Vcard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]