[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Crash: Midi and Instrument_name_engraver in StaffGroup (was Re: TAB ques

From: Trevor Daniels
Subject: Crash: Midi and Instrument_name_engraver in StaffGroup (was Re: TAB question -- frescobaldi tab support)
Date: Tue, 17 Feb 2009 23:34:54 -0000

This looks like a bug. An attempt to add the Instrument_name_engraver to a StaffGroup context *and* produce MIDI output causes a Crash under Vista. Doing either separately is fine. Here's a minimal example:

\version "2.12.2"
\score {
 \new StaffGroup \with { \consists Instrument_name_engraver }
 \midi { }


----- Original Message ----- From: "Grammostola Rosea" <address@hidden>
To: <address@hidden>
Cc: "Wilbert Berendsen" <address@hidden>
Sent: Tuesday, February 17, 2009 10:07 PM
Subject: Re: TAB question -- frescobaldi tab support

Daniel Hulme wrote:
On Tue, Feb 17, 2009 at 10:25:19PM +0100, Grammostola Rosea wrote:

My default Debian lenny version, works ok. But how do I install the newest lilypond on Debian testing?
When I install the sh script, it doesn't work properly.

In what way? Please give any error messages.

I think there is a bug here!? Or a fault in the template?
When I comment out this:

%\consists "Instrument_name_engraver"
   %instrumentName = "Electrische bas"

It runs ok.


\version "2.12.2"

\include ""

global = {
 \key g \minor
 \time 4/4

electricBass = \relative c {
 % Muziek volgt hier.
 e,4\4 g\4 a\3 d8\3 c\3 e2\4

\score {
 \new StaffGroup \with
  %\consists "Instrument_name_engraver"
   %instrumentName = "Electrische bas"
   \new Staff \with {
     midiInstrument = "electric bass (finger)"
   } { \clef bass \electricBass }
   \new TabStaff \electricBass
 \layout { }
 \midi {
   \context {
     tempoWholesPerMinute = #(ly:make-moment 100 4)

lilypond-user mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]