[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug? Lines disappear with rhythmic staff

From: M Watts
Subject: Re: Bug? Lines disappear with rhythmic staff
Date: Sat, 28 Mar 2009 16:59:09 +1000
User-agent: Thunderbird (X11/20081105)

Peter Chubb wrote:
I'm using the current 2.12.2 version of lilypond.  The attached file
   programming error: vertical alignment called before line-breaking
and no lines on the staff.

If I remove the \bar "|." the output is correct.

\version "2.12.2"
recscore=  \context StaffGroup <<
    \context RhythmicStaff = "tambour" {
      \override NoteHead   #'style = #'cross
f4 f8 f8 }
    \context Staff = "recA" {
      \clef "G^8"
      \bar "|."

\score {
 \layout {
    \context{ \RhythmicStaff
              \remove "Time_signature_engraver"
              \remove "Staff_symbol_engraver"
              \remove "Clef_engraver"
%             \remove "Bar_engraver"
              \consists "Instrument_name_engraver"
              \override BarLine #'transparent = ##t
    \context{ \Staff
              \remove "Time_signature_engraver"


For me, with 2.12.2 on Fedora 10, running your example yields tiny staff lines before the clef, but nothing after, and no StaffGroup bracket.

You seem to have removed the Staff_symbol_engraver from the RythmicStaff context -- I left the \bar "|." in, and commented out the line

%  \remove "Staff_symbol_engraver"

, then all worked fine.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]