[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tempo mark alignment

From: Jay Anderson
Subject: Re: Tempo mark alignment
Date: Sat, 23 May 2009 16:48:22 -0700

On Sat, May 23, 2009 at 7:49 AM, Reinhold Kainhofer
<address@hidden> wrote:
> Actually, this bug is not that easy. I was also quite annoyed by this a while
> ago, and started looking at it, but I ran into dead ends. This is one of the
> things that makes my orchestral scores not look quite as professional as they
> could be. Otherwise I would have submitted a patch already, but the problem is
> simply over my head.

What are the issues with Neil's patch? I've been playing around with
it and it seems to do what I want. Well, it's a similar patch really
(see attached).

Neil's comment from Issue 684: "The stumbling block is how to align to
note columns; I can't work out how the metronome marks get attached to
a paper column when there's no breakable object nearby."

How often is a situation like this encountered (not that I really
understand what it means)? The most common usage (tempo mark on the
bar) works fine. Perhaps if it can't be worked out we could create a
patch that works in 99% of cases and leave an enhancement open to work
on the other cases later.

Thanks for the help. (Also sorry about starting another one of "those"
threads. That was not my intention.)


Attachment: tempo_alignment.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]