[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling on MAC OS X 10.5.7

From: Simon Mackenzie
Subject: Re: Compiling on MAC OS X 10.5.7
Date: Fri, 19 Jun 2009 20:43:38 +0700

On 19/06/2009, at 11:21 AM, Graham Percival wrote:

On Fri, Jun 19, 2009 at 09:08:11AM +0700, Simon Mackenzie wrote:
On 19/06/2009, at 8:37 AM, Tim McNamara wrote:

On 18.06.2009, at 16:05, Simon Mackenzie wrote:
Has any one had any success compiling Lilypond 2.12.2 on a MAC OS
X 10.5.7 system?

What are the errors reported by the compiler?  And why not use the
precompiled binary?

The precompiled version 2.12.2 does not seem to have any menu I can
access to compile lilypond scripts as instructed in the opening editor script. I.e. the only thing that appears in the menu bar is the LilyPond
menu item, no compile menu item.

Compiling from scratch will do nothing about this; compiling from
scratch will just give you the command-line app that already works
as part of the precompiled binaries.

If you're seriously interested in fixing this, search the -devel
mailist for the numerous discussions about what Apple broke in
10.5.  But if you're not prepared to do a fair amount of low-level
hacking in python and OSX packages, then I highly advise you to
either use the command-line version, or use jedit (lilypondtool, I
think it's called?)

- Graham

Thanks Graham
I'll look into setting up jEdit as you suggest.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]