[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No Work!

From: James Lowe
Subject: Re: No Work!
Date: Thu, 17 Dec 2009 14:37:56 +0000
User-agent: Thunderbird (Windows/20090812)


Don't worry, we all want this to work for you :)

The simple fact is that the latest version of Lilypond (2.13.x) should simply be able to be dragged to your desktop or application folder and you can double click it and you get the welcome screen.

There is no need at all that you should need to use the 'command line' or 'terminal' for this simple function. I know this because I use Lilypond every day on my mac.

I created these screenshots here myself from my own machine using version 2.13 that was current last week.

So i do not think the problem is with you at all.

Indeed you are able to get this working on an external disk - which makes no real sense to me, only because if it works on an external disk it should work on an internal disk, the operating system is the same. The only difference is that the 'physical' path to the external disk from your desktop would be different than to the 'internal' disk.

Q1. You have had a more fundamental problem from the screenshot you sent, and that is (please correct me if I am wrong) that you do not even get the 'file', 'Edit', 'Compile', 'Font', 'Window' or 'help' menus. At least that is what your very small screenshot seemed to show?

Q2. Now when you run the on your external disk you DO see these menus and you can compile the file?

I am unable to reproduce your problem (obviously) however I wonder if you get any kind of messages in the 'console' application that comes with mac?

1. Using Spotlight look for 'console' - you may already know where this app is, but Spotlight will locate it for you. Double click and open this file. You will see a simple GUI with a list of log name sthat you can click on, on the left and the information in the log on the right.

2. Make sure your is not running (quit from it).

3. Now in the click on the 'system messages' entry in the left hand window, now scroll to the bottom of the messages that are displayed (use the scroll bar on the right hand side), the last line is the most current message.

4. Now with this console application open, try to reproduce the problem you have had and see if you get any messages reported in this log while you are doing this. I am not saying you will, but if there are some problems with your 'system' or if the software is trying to do something that it cannot, then I am hoping to see some messages here.

Now be careful, as a running system can generate a lot of system messages normally, (even if nothing is wrong) so try to do this with all your applications (except Lilypond of course) quit.

5. This *may* give us some clues (I cannot promise it will or even promise that if we get messages we will know what they mean) but if you do see anything I would suggest that you then quit Lilypond and do the same steps but on your external driver (where you knwo it works) and see if YOU can see any difference...perhaps warnings or errors do not occur when you run it on your external drive for example.

As I say, this is just basic troubleshooting.

Also, as matter of course if I were to see some behaviour like this (where it works on one disk but not another) I would also consider running 'disk test' application and run the 'check/verify' command to see if there are any filesystem problems that you may not be aware of that might be causing this. I say this because the difference between the two physical volumes is not only there location, but also they will have two independent filesystems.

I hope this helps.


Robert Ley wrote:
The problem I had was not related to the script that I downloaded.
The problem I had was very simple and not related to me creating anything. The page you refer to is about using Terminal to create music pages. I didn't get that far for the following reason: The problem I had was that LilyPond would not compile, at all, the first page that opens in the program. Or a plain text file, saved as an .ly file, with the following on it: { a b c d e }. Would not work period. It seemed to me that if the page the authors created would not compile [in fact there weren't even any menu items available] then it didn't make sense to try and make something else. So I didn't. Here is the ONLY thing I see in the menu bar when I open the program.

Is that any clearer?
Please don't lose patience with me. I'm trying, OK?
Personally, I would attribute the lack of a functioning lilypond on your computer to your inexperience with the method you tried, and if that were the only method, I would certainly take tons of time to diagnose exactly how your system is configured, and how to solve you problems. However, there are at least three other methods avaiable, all of which are more likely easier and better able to suit your needs currently and in the future for progress with LilyPond, so before I spend the time trying to figure out how your computer is set up, and teach you enough to be able to use the Terminal well, I'd suggest using a method that people with far more experience with the Terminal actually use.

Again, I did not get that far. The program will not compile the first page that shows when the program is opened. I have tried to include the mailing list by hitting "reply all" but they kept getting bounced back to me. I just went in and signed up for the mailing list, so that hopefully now they won't bounce back. I had been sending them to the /gmane/ forum. I've changed that, I hope, by subscribing.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]