[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug in 2.13.44-1?

From: Tim McNamara
Subject: Re: Bug in 2.13.44-1?
Date: Fri, 7 Jan 2011 23:26:52 -0600

On Jan 7, 2011, at 5:10 PM, Neil Puttock wrote:

> On 4 January 2011 14:47, Tim McNamara <address@hidden> wrote:
>> Sure, since all of my .ly files fail to compile with 2.12.3 that's easy.  
>> Here's a whole file that fails for me.  There's no melody notated as of yet, 
>> which simplifies things.
> I can't see why you'd be having problems with 2.12.3, but the error
> message you originally posted concerns the `' file.
> Assuming the file you're using is the same as the example posted here,
>, the
> crash occurs in 2.13 due to the change in calling convention for
> chordRootNamer: it takes two arguments rather than one.
> If you change the following line,
> #(define (chord-name->pop-markup pitch)
> to this,
> #(define (chord-name->pop-markup pitch lowercase?)
> your files should compile cleanly.
> Since you're getting crashes without an explicit \include for
>, it would seem this file is being included in another
> file (or you've set it up to load automatically).

Thanks, Neil.  Since the error message didn't reference, I 
assumed the problem was with the file identified in the error message.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]