[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with lilypond and lion?

From: Alberto Simões
Subject: Problems with lilypond and lion?
Date: Tue, 20 Dec 2011 18:18:10 +0000
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0) Gecko/20111105 Thunderbird/8.0


I am using lion and having some trouble with Lilypond.

When I run it using the application icon under Applications, I get:

LilyPond Error
An unexpected error has occurred during execution of the main script

ImportError: dlopen(/Applications/, 2): Symbol not found: _objc_sync_notify Referenced from: /Applications/
  Expected in: /usr/lib/libobjc.A.dylib

I usually run lilypond from the command line, and with Leopard, I had the following alias:

lilypond='DYLD_FALLBACK_LIBRARY_PATH= /Applications/'

and it worked fine. With the new version, I get this other, different, error:

dyld: Library not loaded: @executable_path/../lib//libstdc++.6.dylib
Referenced from: /Applications/
  Reason: image not found
Trace/BPT trap: 5

Any hint? Anything I can do to solve this issue? Or the way to go is to.. argh... compile it?

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]