[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to find file "ice-9/boot-9.scm" in load path

From: Ralph Palmer
Subject: Re: Unable to find file "ice-9/boot-9.scm" in load path
Date: Thu, 2 Feb 2012 13:18:00 -0500

On Tue, Jan 31, 2012 at 2:03 AM, Helge Kruse <address@hidden> wrote:
I think this is better in the bug mailing list. Thererfore I sent it here again.

I try to follow the instructions on this page:

Unfortunately I get an error message, when I try to start guile.exe:
 ERROR: In procedure primitive-load-path:
 ERROR: Unable to find file "ice-9/boot-9.scm" in load path

The PATH contains the path to Lilypond: "C:\Program Files (x86)\LilyPond\usr\bin". So I am sure that I use this copy of Lilypond.

The documentation mentions that I have to add an environment variable
C:\> set GUILE_LOAD_PATH="../usr/shr/guile/1.8"
-- same error
The same appears with each of these settings:
GUILE_LOAD_PATH="C:/Program Files (x86)/LilyPond/usr/shr/guile/1.8"
GUILE_LOAD_PATH="C:/Program Files (x86)/LilyPond/usr/share/guile/1.8"
GUILE_LOAD_PATH="C:\Program Files (x86)\LilyPond\usr\share\guile\1.8"

Let's check if the directory in GUILE_LOAD_PATH is valid:
C:\> dir /b %GUILE_LOAD_PATH%\ice-9\bo*

Now I am convinced that the GUILE_LOAD_PATH is correct. But I failed to start the GUILE prompt. Is there something that I have missed? Is there a way to learn Scheme with my Lilypond 2.14.2?

I am running Lilypond on Windows-7 (64bit) German.


Greetings, Helge -

I am running LilyPond 1.14.2 under Windows XP SP3. I can run LY, and cannot duplicate your error. I've copied it back to the user list, since I cannot confirm the problem as a bug. Can anyone out there help Helge?

Take care,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]