[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond not rendering PDF on Mac

From: Michael Hendry
Subject: Re: Lilypond not rendering PDF on Mac
Date: Tue, 8 Jan 2019 22:18:10 +0000

> On 8 Jan 2019, at 17:32, Stephen Wilkinson <address@hidden> wrote:
> Sorry, not sure if I've posted this twice
> I've recently installed Lilypond (2.18.2) onto a new Mac (OS X 14.2),  but 
> have run into a problem at the beginning. Lilypond hangs when rendering a 
> file at the 'Converting to .pdf.' stage. 
> I've tried this both with the default test file and scores I've already got, 
> and both through and without Frescobaldi. I've got it rendering to SVGs as a 
> workaround, but Frescobaldi's handling of them isn't quite as fluent, so it 
> would be nice to be able to make PDFs as normal. Any ideas? Thanks

Hi, Stephen.

This is all sounding very familiar - I switched to Mac in 2013, and I’m sorry 
to say I solved this or a similar problem without taking note of how I did it.

I think it may have had to do with the installation of (the right version of?) 

I would suggest you check that you can run Lilypond in command-line mode using 
the “-ps” switch to generate a PostScript file.


If that works, and inspection of the resulting .ps file with a text editor 
looks credible, the conversion of PS to PDF is your problem.

You should already have a copy of “ps2pdf” installed, along with lilypond.

Try entering...

which ps2pdf

…on the command-line and see what you get.

On my Mac I get:

| => which ps2pdf
ps2pdf is /usr/local/bin/ps2pdf
ps2pdf is /Applications/
ps2pdf is /usr/local/bin/ps2pdf

I’m not sure how lilypond finds ps2pdf (or equivalent) when it converts a PS to 
a PDF file, but if you have a working copy of ps2pdf on your Mac it needs to be 
in the path that lilypond searches for executables.

Sorry not to be more specific, hope this helps.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]