[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] XFree86 package

From: Ken Gilmer
Subject: Re: [Ltib] XFree86 package
Date: Wed, 15 Aug 2007 10:35:38 -0400

Hey Stuart,

Ok, thanks for that. I just looked in the dist/lfs directory, saw that package, and assumed it would work. I have some questions still :). So is the general rule that packages in /var/freescale/ pkgs are supported packages and those in dist/lfs are not? IRT the new LTIB features that you mentioned, do you have a rough time when you expect to release?

Also, in terms of full distribution vs LTIB, could you clarify where the line is? What else beside XFree86 do you as out of scope. And, is the reason for this distinction technical or simply a matter of overhead and maintenence time?

Ken Gilmer

Bug Labs

On Aug 15, 2007, at 3:42 AM, Stuart Hughes wrote:

Hi Ken,

This package is not supported, only the ones selectable from the config system are likely to build, but sometimes even then not on all platforms (as sometimes a package gets put in for one architecture, but not fully
built/tested for all).

I have a lot of pending changes to go into LTIB which I hope to get in
once I've finished another internal project. One of these changes is to
add proper handling of pkg-config and linking indirect library
references.  This would help a great deal with something like XFree86.

In terms of philosophical approach LTIB is not intended to be a full
distribution as there are many good ones about.  For me it's there to
address the availability of a common userspace package set that can
scale down to smaller devices.

Regards, Stuart

On Tue, 2007-08-14 at 17:32 -0400, Ken Gilmer wrote:

Hello ~

    I'm trying to build the XFree86 LTIB package and am running into
errors very early in the build process.  Is this package supported?
I'm using a BSP provided with the i.MX31 development board.


Build output:

address@hidden ltib-imx31ads-20070128]$ ./ltib -m scbuild -p

Processing: XFree86
rpmbuild --dbpath /home/kgilmer/julyeffort/ltib-imx31ads-20070128/
rpmdb --define '_unpackaged_files_terminate_build 0' --define
'_target_cpu arm' --define '__strip strip' --define '_topdir /home/
kgilmer/julyeffort/ltib-imx31ads-20070128/rpm' --define '_prefix /
usr' --define '_tmppath /home/kgilmer/julyeffort/ltib-
imx31ads-20070128/tmp' --define '_mandir /usr/share/man' --define
'_sysconfdir /etc' --define '_localstatedir /var' -bc --short-
circuit /home/kgilmer/julyeffort/ltib-imx31ads-20070128/dist/ lfs-5.1/
Executing(%build): /bin/sh -e /home/kgilmer/julyeffort/ltib-
+ umask 022
+ cd /home/kgilmer/julyeffort/ltib-imx31ads-20070128/rpm/BUILD
+ cd /home/kgilmer/julyeffort/ltib-imx31ads-20070128/rpm/BUILD/
+ make World WORLDOPTS=

/bin/sh: ./config/util/printver.exe: cannot execute binary file
Building XFree86.

I hope you checked the configuration parameters in ./config/cf
to see if you need to pass BOOTSTRAPCFLAGS.

Tue Aug 14 15:42:45 EDT 2007

cd ./config/imake && make  -f Makefile.ini BOOTSTRAPCFLAGS=""
CC="gcc" clean
make[1]: Entering directory `/home/kgilmer/julyeffort/ltib-
rm -f ccimake imake.o imake
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a tags TAGS
make.log \#*
rm -f -r Makefile.proto Makefile Makefile.dep bootstrap
rm -f imakemdep_cpp.h
make[1]: Leaving directory `/home/kgilmer/julyeffort/ltib-
make  Makefile.boot
make[1]: Entering directory `/home/kgilmer/julyeffort/ltib-
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS="" CC="gcc"
make[2]: Entering directory `/home/kgilmer/julyeffort/ltib-
DCROSSCOMPILEDIR="" in config/imake
gcc -o ccimake -DCROSSCOMPILEDIR=\"\"  -O -I../../include -I../../
imports/x11/include/X11 ccimake.c
if [ -n "" ] ; then \
/cc -E `./ccimake` \
-DCROSSCOMPILE_CPP imakemdep.h > imakemdep_cpp.h; \
else touch imakemdep_cpp.h; fi
gcc -c  -O -I../../include -I../../imports/x11/include/X11 `./
ccimake` imake.c
/bin/sh: ./ccimake: cannot execute binary file
gcc -o imake -O -I../../include -I../../imports/x11/include/X11 imake.o
make[2]: Leaving directory `/home/kgilmer/julyeffort/ltib-
rm -f ./config/makedepend/Makefile.proto
./config/imake/imake -I./config/cf  -s ./config/makedepend/
Makefile.proto -f ./config/makedepend/Imakefile -DTOPDIR=../.. -
./config/imake/imake: ./config/imake/imake: cannot execute binary file
make[1]: *** [config/makedepend/Makefile.proto] Error 126
make[1]: Leaving directory `/home/kgilmer/julyeffort/ltib-
make: *** [World] Error 2
error: Bad exit status from /home/kgilmer/julyeffort/ltib-
imx31ads-20070128/tmp/rpm-tmp.64030 (%build)

RPM build errors:
     Bad exit status from /home/kgilmer/julyeffort/ltib-
imx31ads-20070128/tmp/rpm-tmp.64030 (%build)
Build time for XFree86: 3 seconds

Failed building XFree86

LTIB home page:

Ltib mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]