[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] Trouble adding new package in LTIB

From: Peter Barada
Subject: Re: [Ltib] Trouble adding new package in LTIB
Date: Wed, 13 Aug 2008 14:00:34 -0400

On Wed, 2008-08-13 at 10:19 -0700, James E. Chargin Jr. wrote:
I'm using LTIB on Ubuntu 7.10, targeting the MPC8315e.

Since I've determined that GNU parted is not currently available for 
LTIB, I'm attempting to port parted so it is available on our target.

I've followed the instructions in the LTIB FAQ as best I can but am 
getting an error that I can't find an explanation for.

I downloaded parted-1.8.8.tar.bz2 from fsf. I unpacked it so I could 
later tar it to .gz as is expected by the instructions in the FAQ.

Hmm, then the FAQ is wrong since it supports .bz2 (as specified in your .spec file 'Source' further on).

So, starting with section "How can I add a completely new package to the 
root filesystem" in the LTIB FAQ:

1. First clean your sources...

Since I had just downloaded and untarred the package, I did not "make 
clean". I executed "tar zcvf parted-1.8.8.tar.gz parted-1.8.8"

2. Move this tarball...

I executed "cp parted-1.8.8.tar.gz /opt/freescale/pkgs/

3; Create a specfile...

I executed:
cd .../ltib/ltib-mpc8315erdb-20071129
mkdir dist/lfs-5.1/parted
cp dist/lfs-5.1/template/template.spec dist/lfs-5.1/parted/parted.spec

4: Edit and fixup the template...

My edited specfile is:

%define pfx /opt/freescale/rootfs/%{_target_cpu}

Summary         : GNU parted - partition editor
Name            : parted
Version         : 1.8.8
Release         : 1
License         : GPL
Vendor          : Free Software Foundation
Packager        : xxxx
Group           : xxxx
URL             :
Source          : %{name}-%{version}.tar.bz2
BuildRoot       : %{_tmppath}/%{name}
Prefix          : %{pfx}



./configure --prefix=%{_prefix} --host=$CFGHOST --build=%{_build}

make install DESTDIR=$RPM_BUILD_ROOT/%{pfx}



5. Unpack the new package source:

Here is where I encounter the error. When I execute "./ltib -d -m prep 
-p parted" (I am dry-running to see what it will do), I see the message:

Cannot find spec file that contains the package name parted.
If necessary please give the whole spec file name (with the
.spec extension).

Exiting on error or interrupt

I tried various commands trying to give the full specfile pathname, with 
no success. The last command I tried was "./ltib -d -m prep -p 
.../ltib/ltib-mpc8315erdb-20071129/dist/lfs-5.1/parted/parted.spec" (I 
tried this with sudo also). I got the error message:

get_spec: can't find spec file 

in search any of the directories:

Processing platform: Freescale MPC8315E RDB PowerPC board
using config/platform/mpc8315erdb/.config

Processing: .../dist/lfs-5.1/parted/parted
skipping .../ltib/ltib-mpc8315erdb-20071129/dist/lfs-5.1/parted/parted, 
specfile not found

f_prep() returned an error, exiting
Exiting on error or interrupt

It seems I'm doing something basic incorrectly, but I can't see what it 
might be.

Any suggestions?

Add to config/userspace/packages.lkc a stanza to allow selection of parted, preferably in alphabetical order:

    bool "parted"
        partition manipulation tool

Then add to dist/lfs-5.1/common/pkg_map

PKG_PARTED    = parted

This should get "./ltib -p parted" to find the spec file.

Hope this helps...

Peter Barada <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]