[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] Problems with Requires of libglade.

From: Stuart Hughes
Subject: Re: [Ltib] Problems with Requires of libglade.
Date: Thu, 15 Oct 2009 09:51:48 +0100
User-agent: Thunderbird (X11/20080707)

Hi Rogerio,

This normally happens if there is some utility or script included in the package payload that has #!/usr/bin/python in it at the start. Often you can just drop the offending script from the package (as they're normally not that important). However it depends what it is.

To find the offending file, unpack the rpm or otherwise have the package payload blownout (could use -m scinstall). Then run (all one line):

for i in `find path_to_package_files/ -type f` ; do echo $i ; echo $i | /opt/ltib/usr/lib/rpm/find-requires ; done

This should list the files and the dependencies they pull in, from there you should be able to determine the file and then if not essential, remove from the payload (put an rm -f ..../file_name into the %Install section after the 'make install').

Regards, Stuart

Rogério de Souza Moraes wrote:
Hi folks,

When I try to compile the package libglade in ltib I face the following problem:

sudo /opt/ltib/usr/bin/rpm --root /work/ltib/ltib_2009-10-14_git/rootfs --dbpath /var/lib/rpm -e --allmatches --nodeps --noscripts --define '_tmppath /tmp/ltib' libglade 2>/dev/null sudo /opt/ltib/usr/bin/rpm --root /work/ltib/ltib_2009-10-14_git/rootfs --dbpath /var/lib/rpm --prefix / --ignorearch -ivh --force --excludedocs --noscripts --define '_tmppath /tmp/ltib' /work/ltib/ltib_2009-10-14_git/rpm/RPMS/arm/libglade-2.6.4-1.arm.rpm
error: failed dependencies:
    /usr/bin/python   is needed by libglade-2.6.4-1

Appears that somehow the "/usr/bin/python" is included in RPM. I executed to command bellow to confirm this.

rpm -qpR /work/ltib/ltib_2009-10-14_git/rpm/RPMS/arm/libglade-2.6.4-1.arm.rpm
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

I checked inside the spec and the requires is empty.

If I build this package following the steps:

./ltib -p libglade -m prep
./ltib -p libglade -m scbuild
./ltib -p libglade -m scdeploy

The package doesn't get the (/usr/bin/python) require. Someone already faced it?

Regards, Rogerio


LTIB home page:

Ltib mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]