[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LYNX-DEV Lynx version 2.7 compilation problem (SCO Unix)

From: Bela Lubkin
Subject: Re: LYNX-DEV Lynx version 2.7 compilation problem (SCO Unix)
Date: Sat, 22 Feb 1997 21:05:54 -0800

Jason White wrote:

> In accordance with Wayne's suggestion, I added:
> #define remove unlink
> to the userdefs.h file, just prior to the definition for the location of
> lynx.cfg. I also tried writing REMOVE in uppercase. Unfortunately, the
> same error message occurred when make was run again. I ran
> make clean
> and then:
> make sco
> but still received the error pertaining to the unlink function.

> The uname -X command reports that the system is Release 3.2v4.2. The

I forget the details of this problem.  It *shouldn't* be occurring on
3.2v4.2, which has both rename() and remove() functions.  Perhaps you
have a back-rev version of the development system installed?  Do `grep
rel= /etc/perms/soft` -- what do you see?

As a kludge, add your own remove() function:

remove(const char *filename)
  return unlink(filename);

Save that as remove.c, compile it (`cc -c remove.c`), then add remove.o
to the link line for Lynx.

; To UNSUBSCRIBE:  Send a mail message to address@hidden
;                  with "unsubscribe lynx-dev" (without the
;                  quotation marks) on a line by itself.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]