[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LYNX-DEV Re: "missing highlight on active link"

From: RamNarayan S
Subject: Re: LYNX-DEV Re: "missing highlight on active link"
Date: Fri, 22 Aug 1997 03:49:00 +0500 (IST)

On Thu, 21 Aug 1997, Klaus Weide wrote:


> If your termcap/terminfo says that reverse and underline CAN be used
> together, when in reality they can't, then your terminal description is
> in error.  If the terminal description says that the terminal doesn't
> support underline, but lynx still emits a control sequence for turning
> underlining on, then arguably it is an error in lynx or the underlying
> curses library.  (With Slang it could also be some default assumption
> about a terminal for which no terminal description is available.)

The following is my termcap entry for my term `xterm'.

xterm|vs100|xterm terminal emulator,
    am, xenl, km,
    cols#80, it#8, lines#65,
    bel=^G, cr=\r, csr=\E[%i%p1%d;%p2%dr, tbc=\E[3g,
    clear=\E[H\E[2J, el=\E[K, ed=\E[J, cup=\E[%i%p1%d;%p2%dH,
    cud1=\n, home=\E[H, cub1=\b, cuf1=\E[C,
    cuu1=\E[A, dch1=\E[P, dl1=\E[M, blink=@,
    bold=\E[1m, rev=\E[7m, smso=\E[7m, sgr0=\E[m,
    rmso=\E[m, ich1=\E[@, il1=\E[L, kbs=\b,
    kcud1=\EOB, kf2=\EOQ, kf3=\EOR, kf4=\EOS,
    kcub1=\EOD, kcuf1=\EOC, kcuu1=\EOA, rmkx=\E[?1l\E>,
    smkx=\E[?1h\E=, dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB,
    ich=\E[%p1%d@, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
    cuu=\E[%p1%dA, rs1=\E>\E[1;3;4;5;6l\E[?7h\E[m\E[r\E[2J\E[H,
    address@hidden, rc=\E8, sc=\E7, ind=\n, ri=\EM,
    hts=\EH, ht=\t,

I don't see any entry for smul  (underline),  but my curses seems to be able
to display underlined characters. I use the latest version of ncurses. So,
??? (What next ?)

Now for a clarification  on the behaviour of Lynx.  I have a HTML segment as

<strong><a href="/corweb/dilbert.html">Dilbert!</a></strong> -- Everyone's
favourite engineer.</p></font>

To test your Netscape MIME.type configuration, try the following <a
color+"FF0000">Test Page </a></p>

The  highlight  is on the  Dilbert  anchor on entering  the page.  It is the
first entry in the page.  When I move down from the link towards another, it
shows  underlining for that anchor (<B>  translates to an underline for me).
Now  when I  refresh  the page by a ^L, I get a bold  anchor  instead  of an
underlined  one.  When I walk  over  that  link  again,  I get a  underlined
anchor.  It is not a problem, but looks kinda funny.

>> The above should be         From: &#034Name1 & Name2"    and not as above.
> Ok, but the ac-0.# code does parse the '&#034Name1' as '"Name1', right?

Yep. Works fine!!!

RamNarayan S
+----------------------+-----------------------+--{ o o }--+---------------+
| <<< RamNarayan S >>> |  address@hidden  |    \ /    | HASTEN SLOWLY |
| Strategy  is when you are out of ammunition but keep  right on firing so |
| that the enemy won't know.                          - Unknown            |

; To UNSUBSCRIBE:  Send a mail message to address@hidden
;                  with "unsubscribe lynx-dev" (without the
;                  quotation marks) on a line by itself.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]