[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev wget error

From: John Poltorak
Subject: Re: lynx-dev wget error
Date: Mon, 27 Jul 98 0:09:00 +0000

> On Sun, 26 Jul 1998, John Poltorak wrote:
> > > > <H2>Bad Content Type</H2>Too few parameters were passed to this
> > > > script.<br>
> > > > You must pass at least an action and an owner ID to this script
> > > 
> > > I just tried this with EXTERNAL set to use wget for http transfers,
> > > using lynx2.8.1dev.9 with SunOS 4.1.3_U1. The file was obtained without
> > > problem. What is the exact line in your lynx.cfg for the EXTERNAL use of
> > > wget? Which version of lynx on what operating system are you using?
> > >                              Doug
> > 
> > I'm using OS/2 Warp 3 with Lynx 2.8.1dev.13 and wget 1.5.0 .
> > 
> > 
> > EXTERNAL:http:start "Saving location" /c /f wget -P /in/http -nd %s:TRUE
> I don't know much about OS/2, but it looks like wget is not passing the
> full URL, which contains configuration information to the cgi-bin
> script. I would consider trying to quote %s in whatever way is
> appropriate for OS/2, to make sure that the shell doesn't truncate the
> URL (e.g. '%s', or "%s").
>                                Doug

I've just tried it again, and it looks like the URL includes
characters which are invalid for a filename under OS/2. Including the
'-O' parameter with a target filename in wget retrieves the page fine.

...wonders... is there any way to edit the EXTERNAL commandline just
before it is issued by LYNX. Or even, is there a wget parameter which
would convert a URL into filename which is valid for the local filesystem?

> Doug Kaufman
> Internet: address@hidden (preferred)
>         address@hidden


reply via email to

[Prev in Thread] Current Thread [Next in Thread]