[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev problem with tvgen

From: brian j. pardy
Subject: Re: lynx-dev problem with tvgen
Date: Sat, 3 Oct 1998 19:16:09 -0700

Laura Eaves wrote:
> > Date: Sat, 3 Oct 1998 18:03:29 -0700
> > From: "brian j. pardy" <address@hidden>
> >...
> > I dug around and I wasn't able to reproduce this -- could you possibly
> > tell me how you're getting the error? I tried going to the tv listings
> > page, my zip code has very few channels however, so if it's over-running a
> > buffer or something mine won't cut it. :)
> First, delete (or move) your cookie file.
> Go to
> Cursor down to link 2 ("Enter") and hit return.
> Log on as ricklew with password 3234606
> Cursor down to link 5 ("Search").  Hit return.
> You get the bad request message.

I just tried this using 2.8.1pre.4 and I didn't receive any error. 

What version are you using?

> Exit lynx.  Start up again at
> Cursor down to link 2 ("Enter").  Hit return.
> At this point I get hte bad request message and a blank page.

Right here I receive the login/password page. 

I figure that isn't correct, as I assume following the "Enter" link should
read the login/pw from the cookies stored. 

> Thanks for your help.  I'd like to zero in on what's wrong and
> correct if possible.

No problem at all.

> Did you try it with netscape or MSIE?

I only have Netscape (4.5PR2, Linux), and it all seems to work properly.
Going back to the "Enter" link under Netscape takes me to the grid page,
however, not the main login/password page that Lynx does.

My trace file looks similar to yours:

HTTP: Not sending proxy authorization (yet).
Accept: text/html, text/plain, audio/mpeg, video/x-mpeg2, 
application/postscript, application/x-troff-man, video/quicktime, audio/x-mpeg, 
video/mpeg, application/pdf, audio/x-wav, audio/x-pn-realaudio, 
application/pdf, audio/x-wav, audio/x-mpeg
Accept: video/mpeg, video/quicktime, audio/x-pn-realaudio, 
audio/x-pn-realaudio-plugin, application/pgp-keys, application/x-gunzip, 
application/octet-stream, application/applefile, application/x-metamail-patch, 
sun-deskset-message, mail-file, default
Accept: postscript-file, audio-file, x-sun-attachment, text/enriched, 
text/richtext, application/andrew-inset, x-be2, application/postscript, 
message/external-body, message/partial, image/x-xwd, image/gif, image/*, 
image/jpeg, audio/basic, audio/*
Accept: text/sgml, */*;q=0.01
Accept-Encoding: gzip, compress
Accept-Language: en
Negotiate: trans
User-Agent: Lynx/2.8.1pre.4 libwww-FM/2.14
Cookie2: $Version="1"
Cookie: NGUserID=ce0f6758-17076-907466509-1; 
        TVG_EDNAME=Cox Communications; 
TVG_USER=548514-ricklew-36d2w41dzMiEY-10745-A-85302-99-tv; ZIP=85302

Sending HTTP request.
HTTP: WRITE delivered OK
HTTP request sent; waiting for response.
HTTP: Trying to read 1023
HTTP: Read 278
Read 278 bytes of data.
HTTP: Rx: HTTP/1.0 302 Moved Temporarily 
HTTP: Scanned 2 fields from line_buffer
--- Talking HTTP1.
HTTP/1.0 302 Moved Temporarily
HTTP: Picked up location 

I'm not sure why you are receiving a 400 error from what seems to be the
exact same info sent to the server as my copy is sending -- however, that
extra line in the headers before the TVG_EDNAME pair seems to be why it
isn't logging me in instantly -- the TVG_USER cookie with the
name/password is right after it, and I assume, not getting parsed.

I'll take a look around the source, but it'd be nice if some other people
did as well in case this is a limitation in the length of headers being
sent (does spec allow headers with breaks of some sort?) -- I'm only
familiar with the cookie handling code.

When in doubt, use brute force.
                -- Ken Thompson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]