[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: def7_uni.h (Was: Re: lynx-dev pre.10 : -post_data, nls-fork, various

From: dickey
Subject: Re: def7_uni.h (Was: Re: lynx-dev pre.10 : -post_data, nls-fork, various)
Date: Thu, 15 Oct 1998 05:21:21 -0400 (EDT)

> On Wed, Oct 14, 1998 at 06:08:56PM +0200, Serge MUNHOVEN wrote: 
> > - Broken def7_uni.h : thanks to Leonid Pauzner, Thomas E. Dickey and 
> > Michael Warner for their replies. I seem to be the only one affected and 
> > did 
> > not yet find the true reason for this problem. My system is the same as 
> > Michael's and has been reinstalled from scratch a few months ago. The 
> > problem 
> > still appears in pre9 (no surprise) and also on another system 4.0c. Under 
> > some mysterious circumstances 
> >         printf("%3d", unicount[i]); 
> > is not executed, that's all I can say for now. I hacked around it, but as I 
> > said, I did not find the real answer. 
> I am having problems with def7_uni.h,  too.  My system is SunOS 5.6. 
> The behavior I am experiencing is rather puzzling.  When I run  
> makeuctb def7_uni.tbl 
> with stdout going to the terminal,  I get the complete def7_uni.h 
> displayed.  If I redirect the output to a file,  it gets terminmated in 

I run all of my lynx builds tee'ing to a file.  For example, one of my
wrappers for 'make':

cat >>$OUT <<EOF/
** `date`
** node: `hostname`
** user: `id`
** make: $*
make $* 2>&1 | tee -a $OUT

I can experiment with the parts, but don't see where the problem might lie. 
(You did say SunOS, right?  - That still doesn't give me a clue.  If it
were a very-old system, some did not flush stdout before exit, so that
could be the problem - but you could try putting fflush(stdout) and
fflush(stderr) before the calls to exit).

> the middle.  This happens under different shells (zsh, sh, bash, tcsh), 
> the file gets always truncated on the same place: 
>         {0xfb05,"St"}, {0xfb06,"st"}, {0xfe7d,"3+;"}, {0xfe82,"aM."}, 
>         {0xfe84 
> I finally managed to create def7_uni.h by running makeuctb under 
> `script',  editing the typescript file manually,  and renaming it. 
> So far it seems to be working fine. 
> --  
> Jan Hlav\'{a}\v{c}ek 
> address@hidden  (Blind Carbon Copies will bounce) 
> www: 

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]