[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Re: 2.8.1 fails under cron (with ncurses & nsl-fork)

From: Kim DeVaughn
Subject: lynx-dev Re: 2.8.1 fails under cron (with ncurses & nsl-fork)
Date: Tue, 1 Dec 1998 12:42:17 -0800

On Tue, Dec 01, 1998, address@hidden (address@hidden) said:
| > A few days ago, at my suggestion, one of our sysadmins upgraded lynx
| > from v2.8-rel.2 to v2.8.1-rel.1, on our FreeBSD 2.2.7-STABLE platforms.
| >
| > Immediately, some users who were running "lynx -dump" via cron, started
| > getting failures, using such simple cron'd shell scripts as:
| >
| >  #!/bin/sh
| >
| >  /usr/local/bin/lynx -dump >$HOME/tmp/lynx.out
| perhaps this is breaking because the HTCheckForInterrupt function is being
| invoked (which it shouldn't be when the -dump option is set -- but perhaps
| there's a hole in the logic).

I just tried commenting out the code snippet at HTTCP.c:604 (I think that is
the only place inside the NSL_FORK ifdef where HTCheckForInterrupt is used),
but no joy ... still get exactly the same behavior when cron'd.

| If -dump is set, neither ncurses nor slang should be initialized or
| exercised.

Heh, yeah ... going a bit further, I think it's pretty strange that code
having anything to do with gethostbyname(), is coupled to the selection
of a screen-handling lib.  Especially since I don't really see any diff-
erence with nsl-fork enabled or not.

Anyway, thanks for the suggestion, Tom ... 'twas worth a quick try ...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]