[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Lynx returns error 11 when called from cgi

From: Bela Lubkin
Subject: Re: lynx-dev Lynx returns error 11 when called from cgi
Date: Fri, 11 Dec 1998 17:43:10 -0800

Klaus Weide wrote:

> On Fri, 11 Dec 1998, Faith Zack wrote:
> > Can you tell me what circumstance would cause Lynx
> > to return 11?  I am exec'ing lynx -dump from a java

> > When I run my Java application from a cgi program I get process status=11,
> > but when I run it from the command line (even as user 'nobody') it works 
> > fine (process status = 0).  Any idea what the problem might be?

> Lynx needs access to a lynx.cfg file, add -cfg=... to make sure it
> finds the right one.  Try setting STARTFILE in lynx.cfg to a local
> file://localhost/... URL, and test your app with a file://localhost/...,
> to eliminate domain name lookup problems.

In fact, I recently submitted a fix to a problem that would have caused
name lookups to fail if stdin was a device which could not be select()ed
-- a likely scenario in the CGI environment.

Faith, what version of Lynx is it?  My fix was within the last month, I
think post-2.8.1.  It should be in the current patches archive,

and is definitely in the current ongoing development code,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]