[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Crypto Question

From: Ismael Cordeiro
Subject: Re: lynx-dev Crypto Question
Date: Fri, 1 Oct 1999 17:28:12 -0400 (EDT)

On Fri, 1 Oct 1999, Janina Sajka wrote:

> > Configure doesn't look for SSL. You have to specify its location in
> > The way I do is to set SSL_DIR in to
> > /home/ismael/ssl before configuring.
> > 
> I think I'm doing this, but I still fail to compile. Here're the relevant
> lines from my
> SSL_DIR= ~isrd/bin/lynx282
> SSL_LIBS= -L$(SSL_DIR)/lib -lssl -lcrypto

If "isrd" is your home directory, try using SSL_DIR=~/isrd/bin/lynx282

> On running make, I fail as follows:
> Linking and creating Lynx executable
> gcc -DHAVE_CONFIG_H   -DLOCALEDIR=\"/usr/local/share/locale\"  -I.  -I..  
> -Ichrtrans  -I./chrtrans  -I..  -I../src  -I../WWW/Library/Implementation   
> -I~isrd/bin/lynx282/include -DUSE_SSL -O2  -o lynx  LYClean.o LYShowInfo.o 
> LYEdit.o LYStrings.o  LYMail.o HTAlert.o GridText.o LYGetFile.o  LYMain.o 
> LYMainLoop.o LYCurses.o LYBookmark.o LYUtils.o  LYOptions.o LYReadCFG.o 
> LYSearch.o LYHistory.o  LYForms.o LYPrint.o LYrcFile.o LYDownload.o LYNews.o 
> LYKeymap.o  HTML.o HTFWriter.o HTInit.o DefaultStyle.o LYLocal.o LYUpload.o  
> LYLeaks.o LYexit.o LYJump.o LYList.o LYCgi.o LYTraversal.o  LYEditmap.o 
> LYCharSets.o LYCharUtils.o LYMap.o LYCookie.o LYExtern.o  LYStyle.o LYHash.o 
> LYPrettySrc.o UCdomap.o UCAux.o UCAuto.o 
> ../WWW/Library/Implementation/libwww.a  -lcurses  -lnsl -lsocket   
> -L~isrd/bin/lynx282/lib -lssl -lcrypto
> *** Error code 1
> *** Error code 1

I can't see what's the problem except for a wrong path. Which version of SSL
are you using?

> PS: I've tried using a full path, /helen1/isrd/bin/lynx282 -- but that's
> even worse. make barely gets going before I fail on an error that it can't
> find /helen1/isrd/bin/lynx282/include -- though it's most assuredly there.

Go to that "lynx282" directory and enter "pwd". What does it say?

> Unless ya'all have a specific suggestion, my next thought is to give up
> trying to install to a different location, and just build everything in the
> same dir where I want the executable to reside. It's just my old habit to
> install from some kind of tmp dir--seems cleaner.

I have no specific suggestion. I've never had problems I could not solve when
compiling SSLeay or openSSL and then compiling lynx with SSL. On this system
here my home directory is "/home/ismael", the directory where I compile lynx
is "/home/ismael/lynx", the SSL directory is "/home/ismael/ssl" and
everything works fine.

I hope you'll succeed.

       |                                                             |
       | ISMAEL CORDEIRO            | mailto:address@hidden     |
       | Production sound mixer     |    |
       | Montréal - Québec - Canada | |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]