[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev (key) Hex-ASCII values. . . ?

From: pAb-032871
Subject: Re: lynx-dev (key) Hex-ASCII values. . . ?
Date: Tue, 30 May 2000 05:02:34 -0700


In "Re: lynx-dev (key) Hex-ASCII values. . . ?"
[28/May/2000 Sun 15:27:50]
Klaus Weide wrote:

> On Sun, 28 May 2000, pAb-032871 wrote:
> > <> [...] Adding hex-escaped
> > <> representations, and even pasting an Enter "character", with a hex
> > <> value of 03 into the KEYMAP section of lynx.cfg did nothing.  Messing
> That would be a Control-C character.  I somehow doubt that that's
> correct.  Maybe at some lower keycode level, but not at the ASCII
> level at which lynx should see the characters.

Absolutely right.  I tried typing CTRL-C into the ASCII field
of my hex editor and got 03 in the hex field.  Oddly enough, pressing
Enter *also* produces a hex:03 character.

When I typed CTRL-C in MacLynx, it asked me if I really wanted
to quit. . .  And when I said no, it said "Excellent!!!" [by the
way, whose idea WAS that?  I've always loved that little phrase].

Pressing Enter got me the "press space for more, use arrow keys
to move, '?' for help, 'q' to quit." response.

> My (current) lynx doesn't say
>    press 'k' for list of commands
> when an unrecognized or invalid key is pressed, it says
>    press space for more, use arrow keys to move, '?' for help, 'q' to quit.
> But I assume you mean that (maybe the difference is a customization
> for Mac).

Yes, that's what it says here too.  But maybe it *should* mention
something about the 'k'eymap when you give an unknown command.
Maybe not: there's already something about this in NOVICE mode,
constantly visible.

> So lynx is seeing *some* character value, or it wouldn't produce that
> message.  (I'm assuming that the Mac port is not *completely*
> different from the common code wrt key handling.)  Or possibly a
> sequence of values.  Now you just have to find out which.  Trial and
> error...   (You might also try -trace - *sometimes* unrecognized
> escape sequences, at least, produce some trace output...)

All it did was add "343" to the "press space for more" message.
This wasn't much help at first. . .  Until it was translated;
dec:343 = hex:0157.


Still asks me if I *really* want to quit when I hit CTRL-C too.
Weird, but I'm not complaining.

> Have you tried

A linefeed.  Not a bad idea, but 0A is CTRL-J on this keyboard
[by the way, when I mapped 0x0A:ACTIVATE, CTRL-J worked.  Typing
a linefeed *character* into the keymap also worked.  I'm a little
sorry MacLynx doesn't seem to recognize newlines in its own native
language. . .]

Well, just like it says at the top of this message, THANK YOU!


; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]