[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev "~"/tilde bug?

From: Fiber McGee
Subject: lynx-dev "~"/tilde bug?
Date: Wed, 11 Oct 2000 19:09:28 -0500

The message below from Rick Dyson
<address@hidden> was forwarded
by the list moderator.

    $ Lynx -version
    Lynx Version 2.8.3rel.1 (23 Apr 2000)

    Copyrights held by the University of Kansas, CERN, and other
    Distributed under the GNU General Public License.
    See and the online help for more information.

    OpenVMS platform (note this problem has been reported to me with lots
    of versions of Lynx back to v2.7.x and I have confirmed it on Unix
    platforms too.


    I have found that if a URL includes a tilde "~" character in some
specific URLs (I have not tested for all combinations) the download does
not take place.  The following error is presented on the display:

Alert!: Unable to access document.

    This is easily repeatable.

    For example, this FTP protocol example always fails:

$ lynx
Can't Access `'
Alert!: Unable to access document.

    I suspect the code assumes the "~username" is invalid syntax and
either drops the "~" or just quits before attempting to get the file
from the remote FTP server.  This is a perfectly valid and functional URL
that should be allowable.

Richard L. Dyson                                    address@hidden
 _   _      _____      
| | | |    |_   _|   Systems Analyst                     O: 319/335-1879
| | | | of   | |     The University of Iowa            FAX: 319/335-1753
| \_/ |     _| |_    Department of Physics & Astronomy
 \___/     |_____|   Iowa City, IA 52242-1479

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]