[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Site no longer works with Lynx and ELinks

From: Thomas Dickey
Subject: Re: lynx-dev Site no longer works with Lynx and ELinks
Date: Mon, 6 Jan 2003 20:19:31 -0500
User-agent: Mutt/1.3.27i

On Mon, Jan 06, 2003 at 10:55:59PM -0200, Fr?d?ric L. W. Meunier wrote:
> On Mon, 6 Jan 2003, Thomas Dickey wrote:
> > On Mon, Jan 06, 2003 at 10:25:07PM -0200, Fr?d?ric L. W. Meunier wrote:
> > The garbage is gzip'd data.  Essentially what is happening is that
> > the remote site is sending an error message followed by the actual page
> > content which is gzip'd.  We encountered a site which misbehaved last
> > year - for which I made a workaround (not adding lynx's base-url stuff
> > when dumping the page).
> >
> > Why w3m works?  A couple of possibilities to investigate:
> No, it doesn't :-)

sort of.  I downloaded 3.2.2 and looked at the code, saw nothing obvious
that would do on-the-fly switch from uncompressed to compressed mode.
So I forced w3m to have its accept-encoding to say it doesn't accept
compression.  That let me see the second page - after a few lines of
error messages.  You can probably do that and see the same thing.
> I now logged in.
> Did you try with any GUI browser ? Apparently only IE works.

right now I'm working where the only GUI browser at hand is an older Opera
release.  I can look with the GUI browser in the early morning...

> Sounds like a serious problem and I don't see any complaints.
> The webmaster said it works with his Mozilla 1.2.

mozilla accepts some things that apparently aren't proper html4 anyway.

Thomas E. Dickey <address@hidden>

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]