[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev screen not redisplaying cleanly

From: Thomas Dickey
Subject: Re: lynx-dev screen not redisplaying cleanly
Date: Sun, 13 Apr 2003 15:56:34 -0400 (EDT)

> 13-Apr-2003 11:27 Thomas Dickey wrote:
> > On Sun, Apr 13, 2003 at 08:41:42AM -0600, Pat Walsh wrote:
> >>
> >> When returning from a lynxprog:less file, text from that file
> >> remains interspersed with the text from the lynx displayed doc,
> >> the screen has to be refreshed (^L) to display only the lynx doc.
> > hmm - I haven't done much with lynxprog (but LP noted that I broke it in one
> > place - encoding of blanks in the jump table - which is what I was just
> > starting to fix this morning).  I'll make a note & see if I can repeat this
> A technical note to Tom.
> I think a good place to solve the problem with blanks is in
> LYLegitimizeHREF(), by moving is_url() call up to the top and work around
> different schemes explicitly (LYNXPROG_URL_TYPE, ... FILE_URL_TYPE), and
> remove space escaping code from HTParse().  The only place where the url is
> not passed through LYLegitimizeHREF() is LYEnsureAlsoluteURL().  The third
> place may be somethere in HTTP redirect code, at least in theory.

I did something like that - but modified HTParse() instead, since that
seemed simpler.  (I'll put an update on my ftp area tonight - have been
investigating gnutls, and recall that you have some patches to review
as well).

Thomas E. Dickey <address@hidden> <address@hidden>

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]