[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] lynx2.8.6dev.6

From: Thomas Dickey
Subject: Re: [Lynx-dev] lynx2.8.6dev.6
Date: Mon, 18 Oct 2004 08:46:51 -0400
User-agent: Mutt/1.3.27i

On Mon, Oct 18, 2004 at 10:05:42AM +0900, Atsuhito KOHDA wrote:
> Hmm, sorry but then what is the problem in fact, only
> configuration is the problem or is there any problem?

I'm not sure - when I setup lynx + ncursesw using the UTF-8 display character
set, it's working properly.  Yesterday when I accidentally had ISO-8859-1 as
the display character set, it misbehaved, looked as you had described.  So
I guessed that you might have done the same.

The options menu layout relies on using ncursesw to compute the widths of
multibyte strings, so it can be confused if the display character set does not
match - lynx would do some additional translation between the point where the
layout is computed and where the page is actually rendered.  (I'll have to see
if that aspect can be improved).
> I tested a bit more and
> - there was the same problem on mlterm with LANG=ja_JP.utf-8
> (options menu showed "Display character set" as UNICODE (UTF-8))
> - but if I compiled lynx with "--with-screen=ncurses" (not
> --with-screen=ncursesw !) then lynx seemed to work fine.

That's not what I would expect.  Without the ncursesw, a few pages are
readable, but the options menu is irregular (hardly readable).  I compared
the ncurses and slang versions (they produced the "same" display).

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]