[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] Problem with SSL certificates in Lynx

From: Aki Tuomi
Subject: Re: [Lynx-dev] Problem with SSL certificates in Lynx
Date: Fri, 30 Jun 2006 10:13:32 +0300
User-agent: Mutt/1.5.11+cvs20060403

On Thu, Jun 29, 2006 at 11:10:55PM -0500, Stef Caunter wrote:
> You appear to have lynx built with gnutls, but succeed in testing with 
> openssl. Are you able to build with openssl? Documented usage procedures 
> are done with openssl. The 2.8.5 release will connect without error unless 
> cert is a wildcard cert. You have exported SSL_CERT_DIR and SSL_CERT_FILE 
> appropriately for your shell?
> Stef
> On Mon, 26 Jun 2006, Aki Tuomi wrote:
> >I tried looking thru the mailing list archives and could not find
> >anything useful for the following issue.
> >
> >When connecting to a site with a proper certificate (not self-signed,
> >using a proper CA, listed properly in /etc/ssl/certs) i get error
> >
> >SSL error:Can't find common name in certificate-Continue?
> >
> >This error does not exhibit itself in other browsers, nor when testing
> >with
> >
> >openssl -CApath /etc/ssl/certs -connect site:443
> >
> >I've set SSL_CERT_DIR=/etc/ssl/certs
> >
> >I am now wondering why it won't work when it's done properly. This is
> >most annoying since I am using a commercially signed certificate. If you
> >need more information please don't hesitate to ask.
> >
> >Aki Tuomi
> >
> >
> >_______________________________________________
> >Lynx-dev mailing list
> >address@hidden
> >
> >

Tested with gnutls too, and it worked. So the problem seems to be with
lynx alone. I am using debian stable, so my lynx is the exact thing you
get from debian. I'll compile a debian backport from lynx and test with

Aki Tuomi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]