[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling MingW lynx under Cygwin (was Re: [Lynx-dev] text browsing)

From: patakuti
Subject: Re: Compiling MingW lynx under Cygwin (was Re: [Lynx-dev] text browsing)
Date: Sun, 13 Aug 2006 12:36:01 +0900 (JST)

On Sat, 12 Aug 2006, address@hidden wrote:

> On Sat, 12 Aug 2006 address@hidden wrote:
> > On Sun, 30 Jul 2006, address@hidden wrote:
> > 
> > > On Sat, 29 Jul 2006 address@hidden wrote:
> > > 
> > > OK. I went back through my notes and patches and did some more testing.
> > > Here is a step-by-step guide to building a statically compiled lynx
> > > under Cygwin which will not be dependent on the cygwin dll (i.e. a MingW
> > 
> > ...
> > I tried it and finally successed to build with some efforts.
> > I wrote some comments and questions below.
> > 
> > >            Compiling lynx for MingW under Cygwin
> > > 
> > I want to use precompiled libraries if it's OK.
> > If I should to use patched libraries, please tell me which libraries
> > sould be patched.
> I would presume that the precompiled libraries are OK until proven
> otherwise. I didn't look for precompiled libraries, so I am not certain
> how the patches that they used to compile for MingW differed from what I
> posted. To keep the binary file compatible with Win98, I would try to
> ascertain that they are not dependent on any system files only available
> with WinNT/Win2K/WinXP.

OK.  Thanks.

> > > 2. Compile and install MingW OpenSSL 0.9.8 stable branch
> > 
> > I tried GnuTLS instead of OpenSSL.
> > I used precompiled library:
> > I got from
> OpenSSL uses the environment variable SSL_CERT_FILE to indicate where
> the collection of trusted certificates resides. How does GnuTLS find the
> file if it isn't in the default location which was compiled in?

I don't know well but I suspect that Lynx with GnuTLS doesn't refer
the certificate files because it doesn't show any warnings to the site
which has self-signed certificate.
If it's true, the binary with GnuTLS is inferior to the one with OpenSSL
on this point.

> > I changed these line as below to compile with GnuTLS.
> >     LDFLAGS="-mno-cygwin -static -L/mingw/lib" \
> >     LIBS="-lgdi32 -lmsvcrt -liconv -lgcrypt -lgpg-error -lwsock32" \
> > # I don't know why I have to add "-lgcrypt -lgpg-error".
> I dont' have those libraries on my machine. Are they bundled with
> GnuTLS?

Those are libraries on which are depended by GnuTLS.
I wanted to say that I don't know why the configure script doesn't add
them to LIBS automatically like gnutls itself.
Takeshi Hataguchi
E-mail: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]