[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lynx-dev] SSL Common Name issue & Form Submissions in Lynx

From: Menasheh Peromsik
Subject: [Lynx-dev] SSL Common Name issue & Form Submissions in Lynx
Date: Sun, 04 Dec 2016 01:46:44 +0000

Hello Lynx developers,

I recently used lynx for the automation of logging in to captive portal wifis on Windows 10.

Because they seem to use https, I had to use the non-color version supporting https through OpenSSL.  (Aside:  Why doesn't Google Chrome have any issue using https out of the box?  It doesn't need third party stuff)  

I tried to install OpenSSL from the recommended page, but the installers for the most recent version seem to not be including the necessary DLLs.  So my system worked on my computer, but threw errors because of the missing DLLs when I tried to set it up for friends.  I used Process Hacker to determine that my copy of lynx was using the OpenSSL dlls included with some random Intel software, so I copied those to their lynx install directories and then it worked fine.

However, as part of my script keyed in to log into the WiFi, I press y to ignore the common name issue.  The common name issue appears whenever I go to ANY and EVERY site supporting https.  See attached trace log for attempting with https.

Is this a problem with the dlls I'm using, or something else?  If so, what is the standard way of getting up to date OpenSSL dlls for lynx for Windows now?  If not, what's causing it?


Another issue I had with the automatic WiFi login is that one user found he got a 405 error when signing in to his WiFi via lynx.  Is this related to the SSL issue, or not?  If not, what does lynx do with form submission differently from graphical browsers?

-Menasheh Peromsik

Attachment: LY-TRACE.LOG
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]