[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MIT-Scheme-devel] git pull is failing again

From: Matt Birkholz
Subject: Re: [MIT-Scheme-devel] git pull is failing again
Date: Fri, 21 Aug 2009 18:21:31 -0700

> From: Taylor R Campbell <address@hidden>
> Date: Fri, 21 Aug 2009 17:12:33 -0400
> [...]
> What is the difference between `git pull' and `git pull origin
> master', and what is all this about HEADs and masters and origin
> HEADs and local HEADs and shooting things?

I looked at a couple other git repos like Guile's and Emacs's.  They
have no ref called HEAD.  HEAD is often used as a default... so it may
be the source of some confusion... anyway, I can only guess why your
origin/master was a996c47 instead of 8acc2b0 -- i.e. why this

         + 8acc2b0...a996c47 HEAD       -> origin/HEAD  (forced update)
        error: Ref refs/remotes/origin/master is at
        a996c47f0b70804af9c42cc25b63a14460f56283 but expected

> So far, the process I have used for making changes to the Git
> repository has been `git pull; git add <pathname> ...; git commit -a;
> git push'.  Is there anything wrong with this?  Am I supposed to be
> aware of some sort of branching going on or something?

I do not see anything wrong with that, assuming your HEAD = master.

> Also, in my unclean repository, I just tried running `git pull' again,
> and it complained about precisely the same files.  I ran `git checkout
> -- <those files>', and `git pull' complains about the same problems:
> % git pull
> Updating 944e600..f2b42a4
> error: Entry 'src/microcode/bkpt.h' not uptodate. Cannot merge.
> `git status' lists the same files, too.  So `git checkout' seems to
> have done nothing.

You have reverted the working files but not the index?  Try "git add
--all" after checking out replacements, to sync up index and working
files.  Or revert the index, with git-reset (syncing it to master as

reply via email to

[Prev in Thread] Current Thread [Next in Thread]