[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MIT-Scheme-devel] "Can't find any usable display type"

From: Steve Quezadas
Subject: Re: [MIT-Scheme-devel] "Can't find any usable display type"
Date: Wed, 21 Apr 2010 10:28:52 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20100227 Thunderbird/3.0.3

Thanks. it worked. I posted the solution up on my blog so it will be searchable in google.

- Steve

On 4/18/2010 11:57 AM, Taylor R Campbell wrote:
    Date: Sun, 18 Apr 2010 10:43:22 -0700
    From: Steve Quezadas<address@hidden>

    I just installed mit-scheme on my ubuntu hardy hardon system. I can't
    load the edwin editor for some reason. This is the first time I tried to
    load it, so I manually typed "(create-editor)" on the commandline and I
    got this respone:
     >  1 ]=>  (create-editor)
     >  ;Can't find any usable display type
     >  ;To continue, call RESTART with an option number:
     >  ; (RESTART 1) =>  Return to read-eval-print level 1.

Judging by the config.log you sent earlier, MIT Scheme found neither
what it needs to use Xlib nor what it needs to use your local termcap
implementation.  There should be packages called something like
`x11-dev' and `ncurses-dev' (I don't know what their exact names are;
I don't use Ubuntu) that enable Scheme to do this; install those and
rebuild the microcode -- run `make clean all' in src/microcode/.

    I try loading the editor manually, by typing "edit" and this is what I get:
     >  1 ]=>  edit
     >  ;Value 13: #[compiled-procedure 13 ("editor" #x1) #x1a #x14ba71a]

You need to call the EDIT procedure in order for it to do anything.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]