[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: monit and SSL

From: Christian Hopp
Subject: Re: monit and SSL
Date: Tue, 22 Apr 2003 17:24:32 +0200 (CEST)

On Tue, 22 Apr 2003, Jan-Henrik Haukeland wrote:


> Fredrik Steen <address@hidden> writes:
> > Hi,
> >
> > The SSL support in monit is a very nice and desirable feature in
> > monit, but for me as a packager of monit for the Debian project
> > (which have a very strict seeing on the OpenSSL+GPL issue) I have
> > some comments:
> >
> > GPL is probably incompatible with OpenSSL's license, because the
> > "advertising clause in OpenSSL's license would add an additional
> > restriction on the GPL licensed software. monit links against
> > OpenSSL as default. (can be disabled with the option
> > --without-ssl).

As a result of the discussion mentioned below, a "monit" and a
"monit-ssl" could be shipped, too.

> > In the current state I'm not able to upload monit with ssl-support
> > wichh would be very desireable and a much needed feature.
> >
> > Please see:
> >
> > and numerous other threads on the issue for more information.
> >
> > Any ideas how to solve this?


> Anyway, I'm trailing off here; this looks to me to be a problem
> defined by the debian project and I do not think we are in a position
> to do anything about it. I too think it would be depressing if debian
> choose not to distribute monit with SSL because of a GPL vs. BSD
> licensing problem. Of course, if you think it will help we will
> probably be willing to add any additional statements in the monit
> LICENSE as suggested by the OpenSSL project, like; "This program is
> released under the GPL with the additional exemption that compiling,
> linking, and/or using OpenSSL is allowed."

I think it's a nice workaround.  But maybe we should think of moving to
gnutls.... maybe it just needs some nice interfaces to be able to
choose from one of both.

Just when you think your code is working a lawyer throws and
exception.  Too bad, that ld doesn't throw a warning...

"WARNING: linking library with incompatible LICENSE." (-:

We might have legal problems with binary not orignally shipped with
OpenSSL (everything != FreeBSD|Linux), too.  Thus, we should not
provide any Solaris, HP/UX, AiX, (MacOSX) binary, or?


Christian Hopp                                email: address@hidden
Institut für Elektrische Informationstechnik             fon: +49-5323-72-2113
TU Clausthal, Leibnizstr. 28, 38678 Clausthal-Zellerf.   fax: +49-5323-72-3197

reply via email to

[Prev in Thread] Current Thread [Next in Thread]