[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

configuring monit's httpd

From: Allen Shaw
Subject: configuring monit's httpd
Date: Thu, 8 Jan 2004 17:50:46 -0500

Hi All,

Happy new year to everyone, I'm sure we're all busy enough to forget New
Years' just a week ago.

I have just installed monit, running with a basic config file (shown
below) -- as far as I can see it is not running well (I get no monit http
connection on port 2812 where I expected it; I get no alert or restart on
the service I'm monitoring when it goes down; and, when I run monit with
'quit' argument, I see 'monit: no daemon process found').  So, I ran monit
with the -Iv switch, which pumps out some configuration info and then ends
with the follwing two encouraging lines:

Starting monit daemon
Segmentation fault


(For some reason I can't get the monit -Iv output to write to a file, but I
think you can guess most of it from the following, which is the text of my
control file:)

======= Start text of ~/.monitrc ===============
 set daemon  120           # Poll at 2-minute intervals
 set logfile /var/log/monit #syslog facility log_daemon # Set syslog logging
#                                        # (facility LOG_DAEMON)
# set mailserver, localhost # Set localhost as a fall back
#                                        # if the primary mail server fails
# set mail-format           # Set a default mail from-address for
#  { from: address@hidden }  # all alert messages emitted by monit
 set alert address@hidden  # Send alert to system admin on any event
 set httpd port 2812 and   # Make monit start it's web-server
     use address  # and only accept connection from localhost
     allow localhost       # allow localhost to connect to the server and
     allow admin:monit     # user 'admin' with password 'monit'
  check process apache with pidfile /var/run/
     start program = "/etc/rc.d/init.d/httpd start"
     stop program  = "/etc/rc.d/init.d/httpd stop"
    if failed host port 80 protocol http
       and request "/index.html" then restart

======= End text of ~/.monitrc ===============

I am not sure what could be causing a segmentation fault here, and
unfortunately I'm not yet enough of a programmer to begin guessing.

I'm running monit 4.1.1 on Redhat Linux 7.3

Could anyone recommend a further debug procedure to help me figure out
what's going on?


Allen Shaw                                  address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]