[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [monit] Monit fails to start process occasionally

From: Martin Pala
Subject: Re: [monit] Monit fails to start process occasionally
Date: Sat, 27 Sep 2008 20:29:38 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20080702 Iceape/1.1.11 (Debian-1.1.11-1)

The state was changed to be persistent even across monit restarts, it will be part of next monit release.

You can get the code in cvs:


Martin Pala wrote:

the problem is, that monit was restarted:

[UTC Sep 26 04:35:51] Stopping monit HTTP server [UTC Sep 26 04:35:51] http server: service stopped [UTC Sep 26 04:35:54] Starting monit daemon [UTC Sep 26 04:35:54] Starting httpd at []

The service was running at 04:36:08 and was killed thereafter:
bash-2.05a# date
Fri Sep 26 04:36:08 UTC 2008

bash-2.05a# ps -ef|grep np1
root 27588 1 0 04:35 ? 00:00:00 /bin/sh /opt/meru/np1/scripts/np

bash-2.05a# ps -ef|grep np1

Since the service np1slave is configured with "manual" mode, it's monitoring is disabled after monit start at *04:35:51* (the manual monitoring mode is not persistent on monit restart). At 04:36:08 the service was not monitored (due to monit restart) so monit didn't tried to recover the service.

To solve this problem, you need to enable the monitoring of np1slave after monit start/restart this way:

   monit monitor np1slave

There are several requests from other users as well to have persistent manual monitoring mode (i.e. keep the monitoring state on monit restart once the service monitoring was enabled/disabled). We'll implement it most probably for next monit release.


On Sep 26, 2008, at 1:33 AM, Arut Selvan wrote:

Hi Martin,
The monit version is 3.2.
Please find attached the conf file and log with monit in verbose mode.
The problem process is np1slave. Please let me know what the problem could be. Thanks,

    ----- Original Message -----
    From: "Martin Pala"
    To: "This is the general mailing list for monit"
    Subject: Re: [monit] Monit fails to start process occasionally
    Date: Sat, 20 Sep 2008 22:21:37 +0200

    What is the monit version?
    What is the monit configuration?
    Can you run monit with the -v option and provide the log output
    for the failed restart attempt?


    On Sep 19, 2008, at 7:05 PM, Arut Selvan wrote:

    Hi All,
Monit fails to start a process that it is monitoring /sometimes (
    2 out of 10 times)/
    The process is killed manually (e.g. pkill -9 xyz)
The pid file of the process that died is still intact but monit
    doesn't start the process.
    The monit.log says: monit: Warning process 'xyz' was not started
    after 5 secs.
Changing the mode to active resolved the issue, but I have been
    told to identify the root cause.
I have already tried using strace as per monit FAQ. That resulted
    in a zombie process.
    If I don't use strace, zombie is not created.Please guide me in
    resolving the issue.
I fail to understand why this problem happens once in a while.
    What would prevent monit from starting a process? Appreciate your
    help in this regard.
-- Be Yourself @!
    Choose From 200+ Email Addresses
    Get a *Free* Account at
    To unsubscribe:

    To unsubscribe:

Be Yourself @!
Choose From 200+ Email Addresses
Get a *Free* Account at <>!


To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]