[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PAM authentication

From: Lawrence, Wayne
Subject: Re: PAM authentication
Date: Thu, 5 Jan 2012 13:30:13 +0000

Hi Martin,
Have solved the problem now although pam is enabled on the system and monit reported that pam support was enabled during compilation it seems the pam-devel package is required.
Once i installed that and re-compiled it works like a charm.
Thanks for the quick reply though.

On 5 January 2012 13:22, Martin Pala <address@hidden> wrote:

the message is generated when the libpam was not found during compilations which disables the PAM support in Monit.

Please can you send the config.log (generated when the "configure" script finishes) and the output of "make" during the compilation? Can you also try the pre-compiled binaries from the Monit download page?


On Jan 5, 2012, at 2:17 PM, Lawrence, Wayne wrote:

> Hi,
> I have minot 5.3.2 installed and am tring to use PAM authentication to tighten security but i seem to be having a few problems.
> when i run monit i get
>  Error: PAM is not supported
> To ensure i had compiled monit with pam i re-compiled it
> | Monit has been configured with the following options:      |
> |                                                            |
> |   PAM support:                                  ENABLED    |
> |   SSL support:                                  ENABLED    |
> |   Large files support:                          ENABLED    |
> |   Optimized:                                    DISABLED
> but still the error persists.
> I know pam is working on the server as other services can use it.
> Any pointers greatly appreciated.
> Regards
> Wayne
> --
> To unsubscribe:

To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]