[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Monotone-devel] Re: glibc 2.2. version?

From: Nathaniel Smith
Subject: Re: [Monotone-devel] Re: glibc 2.2. version?
Date: Thu, 24 Mar 2005 13:22:39 -0800
User-agent: Mutt/1.5.6+20040907i

On Thu, Mar 24, 2005 at 09:38:17PM +0100, Henry Nestler wrote:
> This are the outputs, if try to run on SuSE 9.0.
> I test the binary from monotone-0.17-1.i386.rpm:
> # monotone-i386 --version
> monotone-i386: error while loading shared libraries: 
> cannot open shared object file: No such file or directory

This is why the RPM says "fedora core 3" on the box :-)

If you'd like to contribute an RPM for Suse 9.0, feel free.  It
shouldn't be difficult; we ship a .spec file that should work...

> Next:
> # bunzip monotone-0.17-linux.bz2
> # monotone-0.17-linux --version
> monotone-0.17-linux: relocation error: monotone-0.17-linux: undefined 
> symbol: poptGetContext

Strange, that binary should be dynamically linked against popt 1.7,
just like you have.  And popt is a C library, no weird g++ version
skew issues...

-- Nathaniel

Damn the Solar System.  Bad light; planets too distant; pestered with
comets; feeble contrivance; could make a better one myself.
  -- Lord Jeffrey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]