[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Monotone-devel] Re: glibc 2.2. version?

From: Nathaniel Smith
Subject: Re: [Monotone-devel] Re: glibc 2.2. version?
Date: Thu, 24 Mar 2005 13:31:12 -0800
User-agent: Mutt/1.5.6+20040907i

On Thu, Mar 24, 2005 at 01:15:03PM -0800, Nathaniel Smith wrote:
> Yes, yes, we'd love to distribute static versions.  The problem is
> that _there is no longer such a thing as a static build with recent
> glibc versions_, because the glibc maintainers do not think supporting
> this case is important.  If anyone out there makes a static build,
> then yay.  I just tried, and couldn't even get a binary out (even
> ignoring the warning messages about how even though this build is
> static it will still require the same versions of libc be installed at
> run time as if it were dynamic).  Sorry.  We fought this and lost.

Okay, I realized I was doing something dumb, and actually succeeded in
making a static version.  It still warns prominently that it will
not work without having the right glibc shared libraries available,
i.e., it claims to not really be a static build at all, but, hey, in
case anyone wants to try their luck:

-- Nathaniel

Details are all that matters; God dwells there, and you never get to
see Him if you don't struggle to get them right. -- Stephen Jay Gould

reply via email to

[Prev in Thread] Current Thread [Next in Thread]