[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Monotone-devel] OpenBSD 4.0 compile error for monotone 0.30

From: Jeb Campbell
Subject: Re: [Monotone-devel] OpenBSD 4.0 compile error for monotone 0.30
Date: Tue, 31 Oct 2006 09:31:05 -0600
User-agent: Thunderbird (Windows/20060909)

Zack Weinberg wrote:
> On 10/30/06, Jeb Campbell <address@hidden> wrote:
>> I'm looking to try out monotone, but can't seem to get it compiled on
>> OpenBSD 4.0.
> ...
>> In file included from /usr/local/include/boost/config.hpp:44,
>>                  from /usr/local/include/boost/tuple/tuple.hpp:23,
>>                  from
>> /usr/local/include/boost/config/stdlib/libstdcpp3.hpp:48:1: warning:
>> <command line>:8:1: warning: this is the location of the previous
>> definition
> Don't worry about this one.
>> In member function `virtual std::string
>> commands::cmd_ls::desc()':
>> error: use of namespace `std' as expression
>> error: syntax error before `:' token
>> error: `result' undeclared (first use this function)
>> error: (Each undeclared identifier is reported only
>> once for
>>    each function it appears in.)
> This is a known bug.  There is a typo on that line.  If you look, you
> will see "std:string".  Change it to "std::string" and all will be
> well.
> zw

Sorry about that post -- found it in the bug database after that.

Now I'm getting a runtime error after:
./configure --enable-static-boost
?: error: failed to convert string from 646 to UTF-8: 'mtn'

But nls is enabled...  Anyway, I can help debug if someone can direct me.

Again, please CC address@hidden if it is not too much trouble.

Thanks for your time,


Jeb Campbell

reply via email to

[Prev in Thread] Current Thread [Next in Thread]