[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Monotone-devel] MinGW32 buildbot ready

From: Stephen Leake
Subject: Re: [Monotone-devel] MinGW32 buildbot ready
Date: Thu, 06 Mar 2008 06:36:34 -0500
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/22.1 (windows-nt)

Richard Levitte <address@hidden> writes:

> In message <address@hidden> on Sun, 02 Mar 2008 10:27:53 -0500, Stephen Leake 
> <address@hidden> said:
> stephen_leake> I guess you mean for the mtn executable. I didn't
> stephen_leake> realize that was a special case; the mtn buildbot wiki
> stephen_leake> implied it should always be not in $PATH.
> Aha, that's something I've totally missed when I set up my master.
> The original master, for which the wiki page is originally written,
> apparently uses './mtn' or something like that, while I haven't done
> so.  Maybe I should and treat all those who use $PATH as a special
> case...

As long as the buildbot does not do 'install', the mtn in $PATH
_should_ be the "known working" one. So I'm not clear why anything
else is required.

> stephen_leake> > I solved the problem by making a special factory just
> stephen_leake> > for you ;-), so it can be changed further with no
> stephen_leake> > problems.
> stephen_leake> 
> stephen_leake> Ok. I have created scripts that reside in the base
> stephen_leake> buildbot directory; they should be run as:
> stephen_leake> 
> stephen_leake> ../../
> stephen_leake> ../../
> Fixed.  Sorry for the delay, I was travelling over the Atlantic and
> came home sick (still am, but lucid enough to do this kind of small
> task...).

No problem.

These steps work, but now I'm getting weird errors from 'make all';
"g++ - no source files". It worked fine the first time I tried it on
this machine, and it works fine when run in this 'mixed MinGW/Cygwin'
environment on my other machine, but now not on this one - arrgghh!

It does work on this machine when run in 'pure MinGW'. So I need
another exception: ../../

I think the final step is 'make check'? You might as well make that an
exception as well: ../../

Does the output from each command get logged somewhere? It's really
annoying to have to try to duplicate running the command to see the
failure. `twisted.log' only shows the command line and the status, not
the actual output.

-- Stephe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]