[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Monotone-devel] bash_completion test

From: Richard Levitte
Subject: Re: [Monotone-devel] bash_completion test
Date: Mon, 07 Feb 2011 08:22:31 +0100 (CET)

In message <address@hidden> on Sun, 06 Feb 2011 19:30:06 -0500, Stephen Leake 
<address@hidden> said:

stephen_leake> I ran all tests in Cygwin; all pass except bash_completion.
stephen_leake> bash completion works when I run it directly; I can't figure out 
why the
stephen_leake> test fails.

I did quite a lot of work on this yesterday, they got pushed late at
night.  The issue apparently came when the process isn't connected to
a tty, I first noticed it when trying to build a Debian package from
inside emacs.  If you run emacs, you can start it from the build
directory and do this:

  M-x c o m p i l e RET C-a C-k m a k e SPC t e s t / e x t r a . s t a t u s 

And see the result there.  After my changes, the tests pass, even from
within emacs.  At least on Linux, I hope it will be the same on

stephen_leake> I also ran all tests in MinGW; all pass except
stephen_leake> bash_completion. This time it fails because 'mtn_setup'
stephen_leake> isn't defined, which is just bizarre!

Did it say anything else?  mtn_setup is defined in lua-testsuite.lua,
which is (or should be) loaded by extra-testsuite.lua.

stephen_leake> Reading thru, I can't see where the testlib is loaded.

Makefile create run_extra_tests, have a look in there :-)


Richard Levitte                         address@hidden

"Life is a tremendous celebration - and I'm invited!"
-- from a friend's blog, translated from Swedish

reply via email to

[Prev in Thread] Current Thread [Next in Thread]