[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Monotone-devel] bash_completion test

From: Stephen Leake
Subject: Re: [Monotone-devel] bash_completion test
Date: Mon, 07 Feb 2011 22:26:54 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (windows-nt)

Richard Levitte <address@hidden> writes:

> In message <address@hidden> on Sun, 06 Feb 2011 19:30:06 -0500, Stephen Leake 
> <address@hidden> said:
> stephen_leake> I ran all tests in Cygwin; all pass except bash_completion.
> stephen_leake> 
> stephen_leake> bash completion works when I run it directly; I can't figure 
> out why the
> stephen_leake> test fails.
> I did quite a lot of work on this yesterday, they got pushed late at
> night.  The issue apparently came when the process isn't connected to
> a tty, I first noticed it when trying to build a Debian package from
> inside emacs.  If you run emacs, you can start it from the build
> directory and do this:
>   M-x c o m p i l e RET C-a C-k m a k e SPC t e s t / e x t r a . s t a t u s 
> And see the result there.  After my changes, the tests pass, even from
> within emacs.  At least on Linux, I hope it will be the same on
> Windows.

Works for me now on Debian.

Cygwin still fails. Here's the relevant part of tester.log:

===== Testing for the 'propagate' command =====
/Projects/monotone/monotone-build_cygwin/mtn --no-standard-rcfiles 
address@hidden propagate    Current settings.
pwd: /Projects/monotone/monotone-build_cygwin/test/work/extra/bash_completion.
initial_dir: /Projects/monotone/monotone-build_cygwin.
srcdir: /Projects/monotone/monotone/test.
@ . 
@ .
<<failure when expecting 'prop-bra1'>>


exit code: 0

> stephen_leake> I also ran all tests in MinGW; all pass except
> stephen_leake> bash_completion. This time it fails because 'mtn_setup'
> stephen_leake> isn't defined, which is just bizarre!
> Did it say anything else?  

Here's tester.log from the current head:

Test bash_completion

bash_completion:1: expect exists on the path

runcmd: bash, local_redir = false, requested = nil
bash_completion:2: bash --version
GNU bash, version 4.1.9(2)-release (i686-pc-cygwin)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>

This is free software; you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.


exit code: 0

...e\monotone\test/extra/bash_completion/__driver__.lua:4: attempt to call 
global 'qgrep' (a nil value)
stack traceback:
        ...e\monotone\test/extra/bash_completion/__driver__.lua:4: in main chunk
        [C]: in function 'xpcall'
        [string "testlib.lua"]:1129: in function <[string "testlib.lua"]:1097>
no backtrace; type(err) = string

'qgrep' is called before 'mtn_setup'; lua-testsuite is not being loaded.

> mtn_setup is defined in lua-testsuite.lua, which is (or should be)
> loaded by extra-testsuite.lua.


> stephen_leake> Reading thru, I can't see where the testlib is 
> loaded.
> Makefile create run_extra_tests, have a look in there :-)

that specifies extra-testsuite.lua, it doesn't load it into the running
mtn Lua environment.

Somewhere in, there has to be a Lua "load" command for the
testsuite specified on the tester command line. That's what appears to
be not working on MinGW. Since I can't even find it, I have no hope of
debugging it.

-- Stephe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]