[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #31046] Check for lsame obsolete

From: anonymous
Subject: [Octave-bug-tracker] [bug #31046] Check for lsame obsolete
Date: Sat, 18 Sep 2010 07:34:31 +0000
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv: Gecko/20100914 Firefox/3.6.10

Follow-up Comment #7, bug #31046 (project octave):

Fine, thanks.

For the records, where all this discussion started: libblas now is part of
/usr/lib - at least since MacOSX 10.6 (don't know about 10.5 but I'm sure it
was not there with 10.4), cf.

address@hidden ~$ ls -l /usr/lib/libblas.dylib 
lrwxr-xr-x  1 root  wheel  112  4 Nov  2009 /usr/lib/libblas.dylib ->
address@hidden ~$ ls -l /usr/lib/liblapack.dylib 
lrwxr-xr-x  1 root  wheel  114  4 Nov  2009 /usr/lib/liblapack.dylib ->

lsame seems to be part of liblapack.dylib

address@hidden ~$ nm /usr/lib/liblapack.dylib | grep lsame
000000000041d000 T _lsame
000000000041d000 T _lsame_
000000000041cd90 T _lsamen
000000000041cd90 T _lsamen_

and something more is there in libblas.dylib (what means lower cas letter

address@hidden ~$ nm /usr/lib/libblas.dylib | grep lsame
000000000000a0dd t _lsame_

but only both together produce a right check result for lsame if the linker
flag "-framework vecLib" is given... That's what I understand?


Reply to this item at:


  Nachricht geschickt von/durch Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]