[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #35114] Octave 3.5.90: mkoctfile fails to link

From: Lukas Reichlin
Subject: [Octave-bug-tracker] [bug #35114] Octave 3.5.90: mkoctfile fails to link against BLAS/LAPACK
Date: Sun, 25 Dec 2011 10:05:15 +0000
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/534.52.7 (KHTML, like Gecko) Version/5.1.2 Safari/534.52.7

Follow-up Comment #12, bug #35114 (project octave):

John, this would make sense to me if it were consistent throughout all
supported platforms. But it is not. (Debian, some Mac OS X 10.7 do link while
Windows, Mac OS X 10.6 and some 10.7 don't)  I would still prefer the
traditional behaviour where it links against all libraries. Maybe one could
introduce automatic detection of required libraries.

How do you use the  "-p LAPACK_LIBS" and "-p BLAS_LIBS" options?
I experimented with makefile_chol.m

mkoctfile "-Wl,LAPACK_LIBS" "-Wl,BLAS_LIBS" 
          SB03OD.f select.f SB03OU.f SB03OT.f MB04ND.f 
          MB04OD.f SB03OR.f SB03OY.f SB04PX.f MB04NY.f 
          MB04OY.f SB03OV.f

mkoctfile "-Wl,LAPACK_LIBS" "-Wl,BLAS_LIBS" 
          SG03BD.f SG03BV.f SG03BU.f SG03BW.f SG03BX.f 
          SG03BY.f MB02UU.f MB02UV.f

but I got the following error messages:

octave:12> makefile_chol
ld: file not found: LAPACK_LIBS
collect2: ld returned 1 exit status
ld: file not found: LAPACK_LIBS
collect2: ld returned 1 exit status

How do I use this flags correctly?


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]