[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #52172] [mxe-octave] build failure on osmesa 1

From: Mike Miller
Subject: [Octave-bug-tracker] [bug #52172] [mxe-octave] build failure on osmesa 17.2
Date: Wed, 4 Oct 2017 18:49:34 -0400 (EDT)
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0


                 Summary: [mxe-octave] build failure on osmesa 17.2
                 Project: GNU Octave
            Submitted by: mtmiller
            Submitted on: Wed 04 Oct 2017 03:49:32 PM PDT
                Category: Configuration and Build System
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: Build Failure
                  Status: Patch Submitted
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: dev
        Operating System: GNU/Linux



After pulling the latest mxe-octave updates, I am getting a build failures
with osmesa 17.2:

.../mxe-octave/usr/bin/x86_64-w64-mingw32-ld: cannot find -lstdc++
collect2: error: ld returned 1 exit status
scons: *** [build/windows-x86_64-debug/mesa/drivers/osmesa/osmesa.dll] Error
scons: building terminated because of errors.
.../mxe-octave/Makefile:835: recipe for target 'build-only-osmesa' failed
make[2]: *** [build-only-osmesa] Error 2
make[2]: Leaving directory '.../mxe-octave'

I can get the build to succeed with the attached patch file dropped into the
src directory.

jwe - were you able to get osmesa to build somehow without this change? I
tried cleaning and building again and got the same error, I can only build by
patching out these options.


File Attachments:

Date: Wed 04 Oct 2017 03:49:32 PM PDT  Name: mingw-osmesa-2-no-static.patch 
Size: 548B   By: mtmiller



Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]