[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #52556] Octave stops writing to console

From: Georg Wiora
Subject: [Octave-bug-tracker] [bug #52556] Octave stops writing to console
Date: Wed, 6 Dec 2017 03:15:21 -0500 (EST)
User-agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Follow-up Comment #2, bug #52556 (project octave):

Thank you for your recommendations. I tried __run_test_suite__ without having
the effect of lost output. But I finally found a way to reproduce it. I have
to enter the following commands after starting octave:

  printf('This text shows up in my console\n');
  help sym
  printf('This text doesn't show up in my console\n');

The console output ends with the following lines:

     The underlying SymPy string representation (“srepr”) can usually be
     passed directly to ‘sym’: *note @sym/char:: for discussion of the

     See also: syms, assumptions, @sym/assume, @sym/assumeAlso>>

The first printf does print to console while the second doesn't. I still don't
think this bug is specific to symbolic 2.6.0 package, but does occur in other
situations too. I frequently ran into it before starting to use symbolic.

Maybe it is usefull to know, that "help sym" does not print a carriage return
after last line of help text. The input prompt is placed directly after the
last help output. This may be the place where the output breaks.

For completeness I tried the same with geometry-3.0.0 package: Here I could
not reproduce the effect.

  printf('This text shows up in my console\n');
  help points2d
  printf('This text shows up in my console\n');


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]