[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Naming of the complex diagonal matrix class.

From: Jaroslav Hajek
Subject: Re: Naming of the complex diagonal matrix class.
Date: Tue, 10 Mar 2009 06:28:21 +0100

On Mon, Mar 9, 2009 at 11:33 PM, John W. Eaton <address@hidden> wrote:
> On  9-Mar-2009, Jason Riedy wrote:
> | It may be too late to change, but would a patch to make complex
> | diagonal matrices into diagonal complex matrices be accepted?
> | Was where a reason why they were named differently that sparse
> | complex matrices?  I've been making that typo far too often...
> These names are not new, so we should probably not just change
> them as that would force a lot of code to change.  If we decide to
> change the names, would typdefs work to preserve the old names?
> If we do decide to change the names, I would like to consider a larger
> renaming, to use names like  perm_matrix and diag_matrix instead of
> PermMatrix and DiagMatrix, and I'd like to do this at the same time as
> adding namespace(s) to contain all thes names.
> I think any change like this should happen after 3.2.
> jwe

Besides, I think that it's the sparse complex matrix that is misnamed,
not complex diagonal matrices. This scheme is consistent throughout
the rest of naming, where you can combine, e.g. "scalar" or "matrix"
with all prefixes "float_", "complex_", "float_complex_". Similarly
for "diag_matrix". This is fairly useful in declarative macros. The
only thing where this does not work is the "sparse_matrix" where you
need to inject the "complex" into the root name.
I was aware of this when I chose the naming, but changing the sparse
matrix naming didn't seem that important.

RNDr. Jaroslav Hajek
computing expert & GNU Octave developer
Aeronautical Research and Test Institute (VZLU)
Prague, Czech Republic
url: www.highegg.matfyz.cz

reply via email to

[Prev in Thread] Current Thread [Next in Thread]