[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 3.8 Bug Fix update

From: Thorsten Liebig
Subject: Re: 3.8 Bug Fix update
Date: Sat, 09 Nov 2013 10:47:15 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.0

Am 09.11.2013 10:35, schrieb Andreas Weber:
> Am 08.11.2013 09:27, schrieb Thorsten Liebig:
>> Am 07.11.2013 22:33, schrieb John W. Eaton:
>>> On 11/07/2013 03:27 AM, Thorsten Liebig wrote:
>>>> Am 06.11.2013 22:10, schrieb John W. Eaton:
>>>>> On 11/06/2013 04:06 PM, John W. Eaton wrote:
>>>>>> Am I missing something or isn't the issue there that Ctrl-C does work in
>>>>>> most cases, but doesn't work when Octave is inside a call to the sleep
>>>>>> function? And that is only happening on Windows, correct?
>>>> Actually it always happened on Linux and at some time (month ago) I 
>>>> believe it worked fine on Windows...
>>>> It is of course not only about sleeping, I run numeric simulations using 
>>>> Octave as an interface to an external software (http://openEMS.de).
>>>> But if the simulation is running, I cannot abort it using CTRL+C if I need 
>>>> to.  Thus the GUI is currently unusable for me and the users of this
>>>> numeric tool.
>>> How is the external software called from Octave?
>>> jwe
>> Somthing like this:
>> system('/opt/bin/openEMS.sh  file_to_simulate.xml');
>> And the xml-file was written with the Octave interface...
> So a testcase would be:
> system('openssl speed md5')
> which could be aborted with CTRL+C in the terminal:
> octave:1> system('openssl speed md5')
> Doing md5 for 3s on 16 size blocks: 10057975 md5's in 3.00s
> Doing md5 for 3s on 64 size blocks: ^Cans =  2
> octave:2>
> but not in the GUI? Andy
Yes that would be one more test, but it is true for any command issued
by system()
The simplest one is already in the bug report, e.g. something like
system('sleep 10')

We are unable to abort a system call  with CTRL+C in the GUI...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]